[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Some thoughts on the yum tutorial -- one example : galeon



On Wed, 27 Jul 2005 11:58:32 +0100, Timothy Murphy wrote:

> Stuart Ellis wrote:
> 
>>> 8. A few words on what to do about yum errors would be very useful,
>>> perhaps as a FAQ.
>> 
>> Hmm. Could you give an example of a specific yum error ?  I would think
>> that the most common problems are likely to be general network errors.
> 
> I don't think so.
> I think it is clear from postings to the general Fedora mailing list
> that by far the most common problem is dependencies that cannot be
> resolved.
> 
> These generally seem to be due to an injudicious choice of repositories.
> 
> You are the yum experts, but my advice in such a case would be that if
> "yum update" is failing and there is just one problematic package one
> should add "exclude=..." to yum.conf, at least temporarily.
[....]
> I was slightly perturbed by your belief that most yum difficulties arise
> from network problems since this certainly is not the case from my
> reading of postings on yum.

I'm just a thoroughly subtechnoid user, and I mean every syllable of my
.sig motto; so I can't speak to the actual issue. But I do have an example
you might could use.

When I first installed FC4 and had run yum update, I ran yum install
galeon, on the faint chance it might eventually work some day. (I gave up
galeon -- then my favorite browser -- years ago, when its dependency hell
with mozilla got too much for me. I've kept mozilla, which I detest, ever
since on the same faint hope.)

Much to my delight and amazement, it worked. Galeon runs -- on that one
machine.

A few days later, when I tried it again on other newer FC4 installs (on
older machines), I got dependency hell again. And still do. Such galeon
developers as have responded to my post on 7/23 to
gmane.comp.web.galeon.user (titled Dependency hell *again*) don't seem to
think there's anything they can and want to do.

As I said there, I have no idea whether this is a yum problem, a repo
problem, or something still different. (They seem to be saying it's not
a galeon problem.) But if it's not a galeon problem, it *looks* like one
of those two (if they're really different) to such uninformed users as
myself -- and likely gets called one on lists ...

Maybe someone here can at least tell why this trouble is chronic with
galeon/yum, and yet not with epiphany nor firefox. (I've never encountered
it with either, and have been using both for years.)

-- 
Beartooth Senectoflatuloid, Neo-Redneck, Linux Convert
Remember, I have precious little idea what I am talking about.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]