[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Some thoughts on the yum tutorial -- one example : galeon



On Wed, 2005-07-27 at 16:25 -0400, Beartooth SenectoFlatuloid wrote:
[...snip...]
> When I first installed FC4 and had run yum update, I ran yum install
> galeon, on the faint chance it might eventually work some day. (I gave up
> galeon -- then my favorite browser -- years ago, when its dependency hell
> with mozilla got too much for me. I've kept mozilla, which I detest, ever
> since on the same faint hope.)
> 
> Much to my delight and amazement, it worked. Galeon runs -- on that one
> machine.
> 
> A few days later, when I tried it again on other newer FC4 installs (on
> older machines), I got dependency hell again. And still do. Such galeon
> developers as have responded to my post on 7/23 to
> gmane.comp.web.galeon.user (titled Dependency hell *again*) don't seem to
> think there's anything they can and want to do.
> 
> As I said there, I have no idea whether this is a yum problem, a repo
> problem, or something still different. (They seem to be saying it's not
> a galeon problem.) But if it's not a galeon problem, it *looks* like one
> of those two (if they're really different) to such uninformed users as
> myself -- and likely gets called one on lists ...
> 
> Maybe someone here can at least tell why this trouble is chronic with
> galeon/yum, and yet not with epiphany nor firefox. (I've never encountered
> it with either, and have been using both for years.)

Normally I would tell you that you need to address this problem *not*
with us, *nor* with the galeon developers (who have nothing to do with
RPM or yum dependency problems), but on the fedora-list
(http://www.redhat.com/mailman/listinfo/fedora-list/), IRC #fedora or
FedoraForum.org.  But we *did* ask for examples, so here's some free
help with our compliments.  ;-)

I just ran "yum install" and the problem seems obvious to me (and
probably more experienced users), not so much if you're just getting
wet:

[...]
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for galeon to pack into transaction set.
galeon-1.3.21-8.fc4.i386. 100% |=========================|  38 kB
00:00
---> Package galeon.i386 0:1.3.21-8.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: mozilla = 37:1.7.8 for package: galeon
--> Finished Dependency Resolution
Error: Missing Dependency: mozilla = 37:1.7.8 is needed by package
galeon

The galeon package currently in Extras has been packaged to use mozilla
version 1.7.8 (and *only* 1.7.8, that's what the equals sign "=" means).
However:

[pfrields localhost ~]$ rpm -q mozilla
mozilla-1.7.10-1.5.1

So there's the problem.  The galeon package wants mozilla version 1.7.8,
but 1.7.10 is what's on FC4 currently.  If you query Bugzilla for
information on galeon in Fedora Extras, you'll see a bug open for this
problem.  Expect resolution Real Soon Now.

I'm not sure how we can approach this in the yum tutorial, short of
getting into explaining RPM spec tags such as Requires:.  Let's not do
that.

-- 
Paul W. Frields, RHCE                          http://paul.frields.org/
  gpg fingerprint: 3DA6 A0AC 6D58 FEC4 0233  5906 ACDB C937 BD11 3717
 Fedora Documentation Project: http://fedora.redhat.com/projects/docs/

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]