[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: jEdit



Murray McAllister wrote:
On Jan 2, 2008 8:52 AM, Karl Larsen <k5di zianet com> wrote:
    I got jEdit working in a terminal but it doesn't work. If I use $
jedit file1 it comes up and a panel that does nothing comes up in the
way. I tried to make a file and have tried Control-s to save it and it
does not work.

    The instructions seem not to be for a Linux Terminal. Does anyone
here know how to use jEdit?

Karl

Hey Karl,

I'm very excited about jEdit, it has some amazing plug-ins. I'm not
sure how you installed jedit, but this is what I did (to make sure we
are sort of doing the same thing):

1. Downloaded the java installer for the stable release:
http://prdownloads.sourceforge.net/jedit/jedit42install.jar
2. Installed using "sudo java -jar jedit42install.jar"
3. Create a customer application launcher, with the command "jedit"

When "jedit" from the command line it launches correctly. I am not
sure what you mean by the panel, is it possible to provide a
screenshot?
When I run "jedit testing" it launches with a empty, new file named "testing".

One thing I could think of that would cause you problems if you do not
have java installed. On red hat enterprise linux I needed the
java-1.5.0-sun package to be installed.

If you can provide more details/screenshot I am sure someone will be
able to help. Once you get going, I suggest you install the XInsert,
XML, ErrorList, BufferList, SpellCheck, SideKick, and Console plugins
(Go to Plugins- > PluginManager, select the install tab, and tick the
ones you want. Make sure you are connected to the internet at this
point...). To arrange these on your screen: Utilities -> Global
Options. Select docking, then use the drop down list to select where
you want each plug-in. Alternatively you can access them through the
Plugins menu item.

Let me know if you need any extra help, also posting the output of
"rpm -qa | grep java" would be handy...

Kind Regards,

Murray.

--------------------------------------------------------------------------------------------------------------------
pub   1024D/81B3FDEB 2007-09-19 [expires: 2008-09-18]
Key fingerprint = 4ED9 9907 5BF0 4132 2B46  20D1 C0C6 362D 81B3 FDEB
Murray McAllister (Fedora Docs Project / mdious) <murray mcallister gmail com>
sub   2048g/B04CFA0C 2007-09-19 [expires: 2008-09-18]

Your right Murray and I will include a screen shot. That will help. And the way it seems to work is in a Terminal you type $ jedit filename and it then lets you type in what you want. But I see no panels where you can hit save file. I found where they say Control-s will save but it doesn't for me.

Thus my problems.

Karl

--

	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.
  PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]