[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/inkscape/FC-4 .cvsignore, 1.7, 1.8 inkscape.spec, 1.15, 1.16 sources, 1.7, 1.8



Author: denis

Update of /cvs/extras/rpms/inkscape/FC-4
In directory cvs-int.fedora.redhat.com:/tmp/cvs-serv14394

Modified Files:
	.cvsignore inkscape.spec sources 
Log Message:
- Update to 0.44
- Disabled experimental perl and python extensions
- Added pstoedit, gtkspell and LittleCms support



Index: .cvsignore
===================================================================
RCS file: /cvs/extras/rpms/inkscape/FC-4/.cvsignore,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- .cvsignore	14 Dec 2005 09:52:54 -0000	1.7
+++ .cvsignore	25 Jun 2006 18:16:08 -0000	1.8
@@ -1 +1 @@
-inkscape-0.43.tar.bz2
+inkscape-0.44.tar.bz2


Index: inkscape.spec
===================================================================
RCS file: /cvs/extras/rpms/inkscape/FC-4/inkscape.spec,v
retrieving revision 1.15
retrieving revision 1.16
diff -u -r1.15 -r1.16
--- inkscape.spec	14 Dec 2005 09:52:54 -0000	1.15
+++ inkscape.spec	25 Jun 2006 18:16:08 -0000	1.16
@@ -1,5 +1,5 @@
 Name:           inkscape
-Version:        0.43
+Version:        0.44
 Release:        1%{?dist}
 Summary:        Vector-based drawing program using SVG
 
@@ -12,20 +12,28 @@
 BuildRequires:  atk-devel
 BuildRequires:  desktop-file-utils
 BuildRequires:  freetype-devel
-BuildRequires:  gc-devel
+BuildRequires:  gc-devel >= 6.4
 BuildRequires:  gettext
 BuildRequires:  gtkmm24-devel
+BuildRequires:  gtkspell-devel
 BuildRequires:  libart_lgpl-devel >= 2.3.10
 BuildRequires:  libgnomeprintui22-devel >= 2.2.0
-BuildRequires:  gnome-vfs2-devel
+BuildRequires:  gnome-vfs2-devel >= 2.0
 BuildRequires:  libpng-devel
 BuildRequires:  libsigc++20-devel
 BuildRequires:  libxml2-devel >= 2.4.24
 BuildRequires:  libxslt-devel
 BuildRequires:  pango-devel
-BuildRequires:  perl-XML-Parser
 BuildRequires:  pkgconfig
-BuildRequires:  python-devel
+BuildRequires:	lcms-devel >= 1.13
+BuildRequires:  boost-devel
+%{?_with_perl: BuildRequires: perl-XML-Parser, perl-libxml-enno}
+%{?_with_python: BuildRequires:  python-devel}
+%{?_with_inkboard: BuildRequires:	loudmouth-devel >= 1.0}
+%{?_with_gnomeprint: BuildRequires:	libgnomeprint22-devel >= 2.2.0}
+
+Requires:	pstoedit
+
 Requires(post):   desktop-file-utils
 Requires(postun): desktop-file-utils
 
@@ -56,14 +64,21 @@
 --disable-dependency-tracking  \
 --with-xinerama                \
 --enable-static=no             \
+%if "%{?_with_python}"
 --with-python                  \
+%endif
+%if "%{?_with_perl}"
 --with-perl                    \
+%endif
 --with-gnome-vfs               \
---with-inkjar
-# turned off, seems very unstable at this point
-#--enable-inkboard             \
-# temporarily disabled until I can look into it further
-#--with-gnome-print            \
+--with-inkjar                  \
+%if "%{?_with_inkboard}"
+--enable-inkboard              \
+%endif
+%if "%{?_with_gnomeprint}"
+--with-gnome-print             \
+%endif
+--enable-lcms
 
 make %{?_smp_mflags}
 
@@ -104,6 +119,11 @@
 
 
 %changelog
+* Sun Jun 25 2006 Denis Leroy <denis poolshark org> - 0.44-1
+- Update to 0.44
+- Disabled experimental perl and python extensions
+- Added pstoedit, gtkspell and LittleCms support
+
 * Wed Dec 14 2005 Denis Leroy <denis poolshark org> - 0.43-1
 - Update to 0.43
 - Enabled Perl script execution


Index: sources
===================================================================
RCS file: /cvs/extras/rpms/inkscape/FC-4/sources,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- sources	14 Dec 2005 09:52:54 -0000	1.7
+++ sources	25 Jun 2006 18:16:08 -0000	1.8
@@ -1 +1 @@
-97c606182f5e177eef70c1e8a55efc1f  inkscape-0.43.tar.bz2
+f0bf316e15ddc6009976d97388522f85  inkscape-0.44.tar.bz2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]