[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kernel module packages (was - Re: Pre-Review: Asterisk)



On Sun, 2005-04-03 at 13:11 -0500, Tom 'spot' Callaway wrote:
> On Sun, 2005-04-03 at 19:38 +0200, Thorsten Leemhuis wrote:
> 
> > Release: 1.0_7174.1
> > or
> > Release: 1.1.0_7174
> 
> Seems reasonable. Your bugzilla reasoning makes sense.
> 
> Does this syntax look good to people?
> 
> %define modulever 1.0_7174
> 
> Release: 1.%{modulever}

This is better than %{modulever}.1 in the sense that if %{modulever}
changes in a non-symmetrical or otherwise unexpected way, rpm version
comparison can be tuned by bumping the "1" where needed.  In fedora.us
terms, it's essentially the same as the "vepoch".

> Provides: %{name}-version = %{modulever}

Not sure what value "-version" has there.  What's wrong with just using
the usual "Provides: %{name} = %{modulever}"?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]