[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mach/yum build environment help



On Sat, 2005-04-09 at 04:51 -0400, Zing wrote:
> Hello folks,
> 
> I'm new to mach (using seth's mach/yum build environment) and I'm
> wondering if i setup something not right. i've gotten as far as a
> successful build i think but...
> 
> ./build.sh perl-XML-LibXSLT
> Building as i386 on fedora-development-i386-core with branch devel
> Making srpm of perl-XML-LibXSLT
> Run Mach (Y/n):  Removing 8 packages ... ....
> Getting /home/zbuild/build/extras/srpms/perl-XML-LibXSLT-1.57-4.src.rpm ...
> Removing 1 packages ... ....
> Building source rpm perl-XML-LibXSLT-1.57-4.src.rpm
> Installing BuildRequires ......
> Rebuilding source rpm perl-XML-LibXSLT-1.57-4.src.rpm .....
> Collecting results of build /usr/src/rpm/SRPMS/perl-XML-LibXSLT-1.57-4.src.rpm
> Build of perl-XML-LibXSLT-1.57-4 succeeded, results in
> /var/tmp/mach/fedora-development-i386-core/perl-XML-LibXSLT-1.57-4
> Results: /var/tmp/mach/fedora-development-i386-core/perl-XML-LibXSLT-1.57-4
> Build done.
> 

umm did you run 
mach -c

?

if so the all the build results got moved to wherever your cwd was.

> ...that perl-XML-LibXSLT directory is empty... is that normal?  

with mach -c, yes.


> And a second question, I had to change the buildrequires: from
> perl(XML::LibXML) >= 1.57 to perl-XML-LibXML >= 1.57 otherwise i get
> ERROR: BuildRequires not met. Is this something one just needs to do, or
> is it a bug?

dunno - depends on the version of yum you have installed.


-sv



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]