[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Whether tis nobler to break backwards compat or upstream compat...



One of the packages I maintain in Extras (python-quixote) just released
the next stable version (2.0).  This version is not (entirely) backwards
compatible with the current 1.2 version and is not parallel installable.

This begs the question of the best practice for packaging such changes.
Since it is a relatively recent package, do I just "go for it" and
upgrade the devel/FC4 packages, leaving FC3 untouched, or package it as
"python-quixote2" (with requisite installation changes) and thus break
with upstream?

-- 
Shahms E. King <shahms shahms com>
Multnomah ESD

Public Key:
http://shahms.mesd.k12.or.us/~sking/shahms.asc
Fingerprint:
1612 054B CE92 8770 F1EA  AB1B FEAB 3636 45B2 D75B

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]