[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Review/sponsor needed: sqlite2



On Sat, 2005-04-23 at 21:20 +0200, Michael Schwendt wrote:
> A few additional comments on SQLite v2 versus v3:
> 
>  * SQLite v3 file format is incompatible with v2.
>    Databases need to be converted with sqlite utility.

Good to know. Does it warrant adding a note in either of the packages?

> And with regard to any plans on upgrading the FC-3 branch, comments
> on sqlite v2 dependencies:
> 
>  * Package "kannel": not built for FC3
>  
>  * Package "moodss": current FC3 binaries not built with sqlite-tcl

These should be modified to use sqlite2 I'm thinking.

>  * Package "php-pecl-sqlite": built with internal sqlite 2.8.14

A good reason to have some sort of 2.8.x version around externally.

>  * Package "python-sqlite" in FC-3 branch: no deps which use it

And here's where I'm stumped. It's certainly possible to create a
python-sqlite2 package, but parallel install will be broken. Or it could
be patched to have a different module name, but that breaks Python
programs that use it.

Of course, once sqlite2 comes in this package won't be an upgrade
blocker for anything in Core or Extras 4, so I'm wondering if anything
should be done at all about it.

Shall I go ahead and import sqlite2 then?

-- 
Ignacio Vazquez-Abrams <ivazquez ivazquez net>
http://fedora.ivazquez.net/

gpg --keyserver hkp://subkeys.pgp.net --recv-key 38028b72

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]