[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 165615] Review Request: perl-Text-Template - Expand template text with embedded Perl



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: perl-Text-Template - Expand template text with embedded Perl


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=165615





------- Additional Comments From jpo di uminho pt  2005-08-25 11:46 EST -------
(In reply to comment #1)

> Needswork:
> 
> BuildRequires: perl >= 1:5.6.1
> perl is listed as being part of the minimal build environment in the packaging
> guidelines, so this BR appears to be redundant. The explicit version requirement
> doesn't seem to comes from the module itself.

As you said it is redundant (not a blocker).  The explicit perl version comes
from the old Fedora.US template. IIRC it is related to vendor directories.
 
> Nitpick:
> 
>  " || :" after %check isn't really needed for an Extras package, unless you're
> aiming for backwards specfile compatibility with legacy distros.

Also from old Fedora.US/Extras perl template.  I have already changed my perl
specfile generation script to not include it.  Future new perl module specfiles
won't have it (present ones still have it).


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]