[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: gnupg2-1.9.18: 'make check' fails on x86_64



On Fri, 2005-08-26 at 13:19 -0500, Rex Dieter wrote:
> Ville Skytt wrote:
>
> > Untested, but going back to 0.9.11 and adding:
> > 
> >    Obsoletes: libksba = 0.9.12
> > 
> > ...or:
> > 
> >    Obsoletes: libksba = 0.9.12-1.fc3
> >    Obsoletes: libksba = 0.9.12-1.fc4
> >    Obsoletes: libksba = 0.9.12-1.fc5
> 
> Thanks, I like this "Obsoletes" option much better.

Unfortunately you seem to have committed this to CVS:

    Obsoletes: %{name}-0.9.12-1%{?dist}

Three bugs here:

1) Should be %{name} = 0.9.12..., not %{name}-0.9.12...

2) Using %{?dist} in a case like this won't work as expected on distro
upgrades.  See the two suggestions above that would work (ie. one with
only one version based obsoletes, and one with three version-release
based obsoletes).  With the former, going back to 0.9.12 later would
require an Epoch bump (but not to eg. 0.9.13).

3) The corresponding Obsoletes: for -devel is missing altogether.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]