[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Approval Require for kyum [was Re: New Package: kyum]



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thu, 02 Jun 2005 20:50:20 +0200, you wrote:

>Well, I find it less ugly than not shipping some KDE apps for FE4
>because we cannot build them. ;)

I agree with you, that it is better to have a ugly solution, than
no one.

>> For you comment to move /usr/bin/kyum_sysinfo.py into another
>> directory, the upload maintainer has wrote, that the x-bit should
>> be set and the file should stay in /usr/bin, becouse it is
>> possible to call the script as a normal programm.
>> 
>> It will be nice, to get your point of view about this comment.
>
>It is posssible, but it's not mandatory. And currently the script would
>only pollute /usr/bin, comes without any documentation and gives an ugly
>Python traceback when you call it:
>
>$ python /usr/share/kyum/kyum_sysinfo.py 
>Traceback (most recent call last):
>  File "/usr/share/kyum/kyum_sysinfo.py", line 29, in ?
>    releasever = _getsysver(sys.argv[1])
>IndexError: list index out of range
>
>
>$ python /usr/share/kyum/kyum_sysinfo.py bash
>i386 ; athlon ; 3.0

That is a clear answer. I have notify the upstream maintainer,
that he should move /usr/bin/kyum_sysinfo.py into another
directory.

I have add %{_datadir}/kyum as a directory in the file section.

You can found the new version of the package at:

http:/www.herr-schmitt.de/pub/kyum/kyum-0.6.3-5.src.rpm

Best Regards:

Jochen Schmitt

-----BEGIN PGP SIGNATURE-----
Version: PGP Desktop 9.0.0 (Build 2001)

iQA/AwUBQp9vBE9gByurcX4MEQJuDwCg7WqQoHtoXWU/Z8rb5BrcPlyToqgAoNPr
/6CHrSVpnVJZOMfWWChJUUcv
=WENq
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]