[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Request for Review: wpa_supplicant



http://hostap.epitest.fi/wpa_supplicant/

%description
wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
component that is used in the client stations. It implements key negotiation
with a WPA Authenticator and it controls the roaming and IEEE 802.11
authentication/association of the wlan driver.

This is my first package for fedora-extras, so I'm still trying to get the 
hang of things.  Below are my spec and SRPM; it should build on fc3/fc4 i386; 
I haven't tested it on other archs.

http://www.silfreed.net/download/repo/packages/wpa_supplicant/wpa_supplicant.spec
http://www.silfreed.net/download/repo/packages/wpa_supplicant/wpa_supplicant-0.4.2-1.src.rpm

I'd appreciate it if someone could give me a hand with some of the rpmlink 
errors I'm currently getting:

$ rpmlint ../RPMS/wpa_supplicant-0.4.2-1.fc4.i386.rpm
W: wpa_supplicant incoherent-version-in-changelog 0.4.2-1 0.4.2-1.fc4
E: wpa_supplicant non-readable /etc/wpa_supplicant/wpa_supplicant.conf 0600
W: wpa_supplicant service-default-enabled /etc/init.d/wpa_supplicant
E: wpa_supplicant incoherent-subsys /etc/init.d/wpa_supplicant $PROG

"non-readable" config is by-design; this will have passwords in it that one 
might not want all users to see.
"service-default-enabled" should be fine as it will try to latch on to any 
open AP available (useful with ifplugd).
And I just don't understand the other two errors.

-Doug

Attachment: pgp7DyNejHdxf.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]