[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: PHP4 in extras?

Jeff Spaleta wrote:
On 5/16/05, Paul Howarth <paul city-fan org> wrote:

I believe it's an inherent incompatibility. I tried building with php5
from rawhide this morning and it fell over at a PHP version check in
"configure", the error message being "PHP-GTK requires PHP version 4.3.x".

that's interesting.. since the php-gtk website claims  a requirement
PHP version 4.3.4 or later

You might want to track down a one of the php-gtk developers and ask
if the configure
version check is right or if the website is right.

I believe the website is out of date. PHP-GTK used to have two different build systems, a "historical" one and another that relied on PHP being 4.3.x. At version 1.0.1 of PHP-GTK, the "historical" build system was removed, thus PHP 4.3.x was required. The website doesn't reflect this change unfortunately. At the time, I don't think PHP5 had been released (I may be wrong about that though).

I'll try hacking the configure script not to complain about PHP != 4.3.x and see how much further it gets.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]