[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ScriptletSnippets: desktop-database,mimeinfo



rdieter math unl edu (Rex Dieter) writes:

> respectively, but the "GTK+ icon cache" section says (rightfully)
> "Note that no dependencies should be added for this".

This section is wrong. Instead of, it should state that:

* 'Requires(post): gtk2' shall be added for packages shipping icons and
  requiring gtk2 (e.g. typical Gnome2 applications)

* a '%trigger -- gtk2' with gtk-update-icon-cache shall be added for
  packages shipping icons and NOT requiring gtk2 (e.g. KDE applications)

* no additional deps should be added (as stated currently)


Else, when you have a installation sequence of

1. package-A
2. gtk2

with package-A shipping icons, you will get a 5-10 startup penalty
for every gtk2 application because the icon cache is outdated and
'gtk-update-icon-cache' was not executed.




Enrico

Attachment: pgpDArfhgXKFb.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]