[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Buildrequires perl in spec template against guidelines



Hello,

There is an inconsistency between the spec template in fedora-rpmdevtools, 
which has a 

BuildRequires:  perl

and the Package Review Guidelines 
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines
where there is 

 - MUST: A package must not contain any BuildRequires that are listed in the exceptions section of Packaging Guidelines. 

with perl in the exception section of Packaging Guidelines
http://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions



Ville thinks that the guidelines are wrong, that is perl should be allowed to
be a BuildRequires for perl packages.

For more informations, there is a bug I filled, with Ville response:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179426

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]