[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with GLIBC_PRIVATE

Andreas Thienemann wrote:
I've tried packaging twinkle, a sip softphone, for FE but there is a problem with the dependencies.

twinkle is linking against libresolv, but is using some GLIBC_PRIVATE symbols, as objdump shows:

  required from libresolv.so.2:
    0x0d696912 0x00 16 GLIBC_2.2
    0x0d696910 0x00 11 GLIBC_2.0
    0x0963cf85 0x00 10 GLIBC_PRIVATE

Calling nm on the binary shows that the following to symbols are used:
         U __ns_get16@@GLIBC_PRIVATE
         U __ns_name_ntop@@GLIBC_PRIVATE

Question is, how to proceed?
Is this merely a linker problem, that the wrong libraries are linked or is it a problem in the application which shouldn't use these calls at all?

I saw a similar thing with __ns_get16 in a different package a while back. There was a configure test that looked for this symbol in the C library and picked that one if it was present, otherwise it used one provided by the package itself. A similar thing may be happening in your case.

The way I fixed it for __ns_get16 was to tell configure that __ns_get16 was not found in the C library:

export ac_cv_func___ns_get16


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]