[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Packaging questions about libvisual



Hey,

The new version of Amarok needs to update libvisual from 0.2 to 0.4. This
will break dependencies in libvisual-plugins and gstreamer08-plugins
(that's what "repoquery --whatrequires libvisual.so.0" says). I have four
options :
 1) Warn the maintainers of the dependencies, ask them to try to rebuild
their packages with the new version, update in devel and FC-5, and ask the
maintainers to rebuild their packages for version 0.4. That sounds very
error-prone.
 2) Update to version 0.4 only in devel, disabling visualisation plugins in
the new amarok. That's not nice to those who like them.
 3) Update to version 0.4 only in devel, and update amarok only in devel
too. That's not nice, amarok is one of these apps for which you always want
the latest version :)
 4) Create a compat-libvisual020 package and update in devel and FC5. That
sounds like the best solution, but may I create this package and import it
in CVS without review ? Are there guidelines for this type of packages ?

What do you think is best ?


Aurélien
-- 
http://aurelien.bompard.org  ~~~~  Jabber : abompard jabber fr
"Make everything as simple as possible, but not simpler." -- Albert Einstein



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]