[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Python submodule naming



I'm currently working on getting Paste{,Deploy,Script} though the review
process, and Patrice Dumas asks a good naming question in the bug[0]:

    I don't know if the name should be python-paste-deploy or 
    python-pastedeploy. The guidelines don't cover the case of python
    submodules. If it is "This makes a package name format of python-$NAME"
    it seems to be python-pastedeploy, but if one follow "use the name of the
    module that you type to import it in a script" it should be
    python-paste-deploy. The second naming convention is also consistent
    with perl modules naming. 

Anyone have any insight into this ?

luke

[0]: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198288#c2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]