[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 183694] Review Request: gstreamer08-plugins



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: gstreamer08-plugins


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=183694





------- Additional Comments From bugs michael gmx net  2006-03-04 17:42 EST -------
Both work with gst-launch-0.10, and they are examples from the manual page.
I recall there have been similar/same problems with GStreamer/ALSA before.

Suggest an alternative test on how to verify whether this GStreamer works.
What applications need this version of GStreamer?

This different one works:

gst-launch-0.8 filesrc location=test.wav ! typefind ! spider ! audioconvert !
audioscale ! volume ! alsasink

gst-launch-0.8 filesrc location=test.wav ! typefind ! spider ! audioconvert !
audioscale ! volume ! alsasink device=hw:0

$ gconftool-2 -g /system/gstreamer/0.8/default/audiosink
alsasink

[...]

Anyway, I have a few issues with this package:

* Source tarball has not been stripped off of code with legal issues.
  The "removed-sources.txt" for 0.8.11 is included, but the source
  tarball has been upgraded to 0.8.12. [BLOCKER]

* GConf2 scriptlets are incomplete.

* Requiring /usr/bin/gconftool-2, but running "gconftool-2" is unclean.
  Require exactly what you run. If you run "gconftool-2" from $PATH,
  don't require an absolute path.

* Inter-package deps are wrong: references to gstreamer-devel
  [BLOCKER]

* Explicit "Requires: cdparanoia-libs >= alpha9.7" and
  "Requires: libmusicbrainz >= 2.1.1" are not needed, since the
  automatic soname dependencies are present and the minimum versions
  of those packages are available in FC5.

* GStreamer libdir is included in main package already.

* The two executables in this package are Perl scripts and create an
  ugly dependency on Perl. Not a blocker, but not nice. Considering that
  this is just sort of a compatibility package, do we need them?


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]