[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 185215] Review Request: adime - Allegro Dialogs Made Easy



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: adime - Allegro Dialogs Made Easy


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185215





------- Additional Comments From wart kobold org  2006-03-11 19:52 EST -------
MUST
====
* Source tarball matches upstream
  aa71fbe7661e56421cab42e6bca70c7c  adime-2.2.1.tar.gz
* Package (and .spec) named properly
* License file (zlib) included
* Spec file readable, in Am. English
* Compiles and builds cleanly on FC-4 x86_64
* No locale files
* No excessive BR: or Requires:
* ldconfig used in %post/%postun as is necessary
* Not relocatable
* Does not create any directories that it needs to own
* buildroot cleaned up in %install and %clean
* No duplicate files
* permissions ok
* Macro usage consistent
* Contains code, not content
* headers, api docs, and .so library in -devel
* No .la archives
* No desktop file needed

SHOULD
======
* Packages builds in mock (FC4-i386, FC4-x86_64, FC5-i386)
* Did not test the package as I don't have anything useful to build against
  it.

NONBLOCKING
===========
* License is actually the zlib license, which is very similar to BSD.
  However, since the zlib package itself claims a BSD license (rpm -qi zlib),
  this is not a blocker.

MUSTFIX
=======
* "make docs" generates warnings and fails to build the html/rtf documentation
  because the $srcdir/docs/html and $srcdir/docs/rtf directories are missing.
  I suggest adding the following to %prep to suppress these warnings:
    mkdir docs/html
    mkdir docs/rtf
  ...and including docs/html and docs/rtf in %doc

* BuildRequires: texinfo is needed to pull in 'makeinfo' to build the
  info files.  mock builds fail without this.

* rpmlint complains on i386 packages:
  E: adime shlib-with-non-pic-code /usr/lib/libadime.so.0
  W: adime-debuginfo objdump-failed objdump:
/tmp/adime-debuginfo-2.2.1-1.fc4.i386.rpm.30986/usr/lib/debug/usr/lib/libadime.so.0.debug:
Invalid operation
  ...and on x86_64 packages:
  W: adime-debuginfo objdump-failed
  E: adime-devel only-non-binary-in-usr-lib


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]