[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Squirrelmail plugin packaging naming

There are a couple of Squirrelmail plugins I'd like to package. I've worked out things from the packaging side and been successfully using them for a while, but I'm not sure about the naming. Let's take for example the change_pass plugin. Here are some viable options for naming:

1. squirrelmail-plugin-change_pass
2. squirrelmail-plugin-change-pass
3. squirrelmail-change_pass
4. squirrelmail-change-pass

Option 1 from the above is what I've used to date, with the following reasoning:

a) squirrelmail-XXX as opposed to squirrelmail-plugin-XXX makes it sound like XXX is a subpackage of squirrelmail as opposed to some random third party plugin that is completely separate. The use of "*-plugins-*" is not without precedent; see libopensync for example.

b) Although underscores are not normally allowed in names, use of "change_pass" as opposed to "change-pass" makes sense because the PackageNamingGuidelines say "...packages where the upstream name naturally contains an underscore are excluded from this". In this case, underscores are conventionally used by Squirrelmail plugins and this is no exception - see upstream at http://www.squirrelmail.org/plugin_download.php?id=21&rev=1072 .

Comments welcome.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]