[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: development/guile-devel



Rex Dieter wrote:

> Toshio Kuratomi wrote:
> 
>> On Sat, 2006-05-13 at 11:05 +0200, Eric Tanguy wrote:
>>> Le vendredi 12 mai 2006 à 12:32 -0700, Toshio Kuratomi a écrit :
>> 
>>> > libltdl is from libtool.   Seeing as one of the unresolved deps is
>>> > libguile-ltdl something might have changed in the upstream guile that
>>> > needs a change in the guile packaging for Core.  Or it could be that
>>> > your package depends on ltdl directly.  In either case, a
>>> > BuildRequires for libtool-ltdl-devel will probably get you past this
>>> > error.
>>> > 
>>> > If it is a problem with guile you should file a bug like "guile-devel
>>> > should Require libtool-ltdl-devel".
>>> > 
>>> So adding BuildRequires for libtool-ltdl-devel solve the problem and now
>>> the package build fine in mock. My question is : guile have to require
>>> libtool-ltdl or my package have to require it ?
>>> 
>> I strongly suspect that guile-devel needs to
>>   Requires: libtool-ltdl-devel
> 
> guile is one of those guilty packages that include one (or more) dreaded
> .la files.
> 
> I'll go file a bug.

See 
"guile-devel deps missing"
http://bugzilla.redhat.com/191595

-- Rex


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]