[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Incoming: directfb soname problems




Ville Skyttä wrote:
> On Sat, 2006-05-13 at 10:35 -0700, Thomas Vander Stichele wrote:
> 
>> Log Message:
>> new upstream release
> 
> ...which due to the soname change in it, will break stuff and leave yum
> users without all updates until they figure out what repo they need to
> temporarily disable in case they're using ones that have dependent
> packages.
> 
> libdirect-0.9.so.24   -> libdirect-0.9.so.25
> libdirectfb-0.9.so.24 -> libdirectfb-0.9.so.25
> libfusion-0.9.so.24   -> libfusion-0.9.so.25
> 
> This is the second consecutive update to directfb which will cause these
> problems.  I've seen no mail about the change on lists that I follow.
> The packages are built for all repos all the way down to FC-3 (an "EOL"d
> release).  Looks like nothing was learned from the previous directfb
> mess.  *sigh*
> 
> I'm inclined to move the FE-[345] packages at least temporarily away
> from the needsign queue so that it can be discussed/explained why the
> pain is necessary, and if it is, it can be properly announced and people
> (both packagers and users) can prepare.  Objections?
> 

Being the one who caused the directfb disaster the last time *, I say
remove them from the need sign queue for now and contact the maintainer
about this. This will avoid us all a lot of pain. Not many people
actually use directfb, but many have packages installed which can
optionally use it and thus depend on it.

* A new upstream version was needed to get it to build on devel, there
was no package for devel available breaking devel and the maintainer
wasn't responding so I jumped the gun (oops).

Regards,

Hans


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]