[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

help with build error

I sent this to fedora-perl-devel-list a couple of days ago, but since
I haven't seen an answer there yet (and I need to get this resolved),
I thought I should try here...

I recently updated perl-YAML in devel, which broke perl-Module-Build.
I'm trying to fix that by building the latest perl-Module-Build, but
it looks like the old version is getting pulled in, causing a build

  /usr/sbin/mock-helper yum --installroot /var/lib/mock/fedora-development-ppc-core-558ea75def852d85a4d60009e86eb3328d806610/root install  'perl(ExtUtils::ParseXS) >= 1.02' 'perl(ExtUtils::CBuilder) >= 0.15' 'perl(Archive::Tar) >= 1.08' 'perl(Pod::Readme) >= 0.04' 'perl(YAML)'
  Error: Missing Dependency: perl(YAML) < 0.49 is needed by package perl-Module-Build

In case anyone wants to see the full messages:

  Build logs may be found at http://buildsys.fedoraproject.org/logs/fedora-development-extras/9342-perl-Module-Build-0.28-2.fc6/

I really don't see why the older version of Module::Build is getting
pulled in by yum.  As far as I can tell, it isn't a dependency of
anything that Module::Build lists as a BuildRequires.

So far the only solutions I can think of are to either remove the
newer perl-YAML from the repository temporarily, or removing the older

Steven Pritchard - K&S Pritchard Enterprises, Inc.
Email: steve kspei com             http://www.kspei.com/
Phone: (618)398-3000               Mobile: (618)567-7320

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]