[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Greedy install



Axel Thimm wrote:
On Wed, May 17, 2006 at 05:14:27PM -0600, Stephen John Smoogen wrote:
On 5/17/06, Axel Thimm <Axel Thimm atrpms net> wrote:
Hi,

what's the best way to have as many packages as possible installed
(given some special handling, e.g. no additional glibc/kernel)?
E.g. how does on tell yum or any other tool "install fedora extras"?
Does this do it?
yum install ---disablerepo=\* --enablerepo=extras install \*

I guess in principle it should, but

Error: oidentd conflicts with pidentd
Error: Missing Dependency: php = 5.1.2 is needed by package syck-php
Error: Missing Dependency: python < 0:2.4 is needed by package python-reportlab
Error: Missing Dependency: xorg-x11-Xnest is needed by package sabayon-admin
Error: compat-wxGTK2-devel conflicts with compat-wxGTK-devel
Error: compat-wxGTK-devel conflicts with compat-wxGTK2-devel
Error: Missing Dependency: php = 5.1.2 is needed by package php-eaccelerator
Error: uw-imap-devel conflicts with libc-client-devel

So one would not manually exclude the one and other package and get a
maximum install (but it takes ages to compute, I'll do that tomorrow :).

I wished yum had apt's auto-keeping-back feature when it comes to
conflicts and other mismathces on the repo side.
From repoclosure:

Summary of broken packages in fedora-extras-5-i386:
----------------------------------------------------------------------
php-eaccelerator 5.1.2_0.9.3-0.3.fc5.i386 syck-php 0.55-7.fc5.i386 And it looks like the compat-wxGTK-devel doesn't like compat-wxGTK2-devel. That explains about half of the issues.
-Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]