[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Obsoletes in a spec file



On Wed, 2006-05-24 at 07:23 +0100, Paul wrote:
> Hi,
> 
> > > obsoletes: anjuta-1.2.4a-{release}
> > > 
> > > or is there more to it than that?
> > 
> > Why do you want to add that at all?
> > 
> > (anjuta-2.0.2 is an update/upgrade of anjuta-1.2.4a already)
> 
> I've found with the upgrade (rpm -Uhv) things don't work as well as. Do
> rpm -e with the old version and everything is great. 
> 

Why not? If that's true then the older pkg is probably leaving some file
it created around.

in rpm-terms a:
rpm -Uvh is really just:
rpm -i newpkg
rpm -e oldpkg

-sv



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]