[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Obsoletes in a spec file



On Wed, 2006-05-24 at 09:46 +0200, Axel Thimm wrote:
> On Wed, May 24, 2006 at 07:23:53AM +0100, Paul wrote:
>
> > I've found with the upgrade (rpm -Uhv) things don't work as well as. Do
> > rpm -e with the old version and everything is great. 
> 
> Then that's either
> 
> o a bug in %post* %pre* scriplets, and adding obsoletes won't make any
>   difference. You probably get eaten by %postin from the new package
>   being called before %postun from the old one. rpm -e, rpm -i
>   separate these steps (but an explicit obsolete will not, so you'd be
>   back to square 1).
> 
> o (higly unlikely) a bug in rpm

Or the obvious: anjuta 1.2.4a has "Epoch: 1", that needs to be present
in the new one too.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]