[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Broken dependencies on libsysfs.so.1 ??



I maintain the libibverbs package in Fedora Extras, and I've been
getting automated emails saying stuff like:

 > This is an automated mail created by an experimental script.
 > Your following packages in the repository contain broken dependencies:
 > 
 > package: libibverbs - 1.0.3-1.fc6.i386 from fedora-extras-development-i386
 >   unresolved deps: 
 >      libsysfs.so.1

Ordinarily, I would understand that, but the mystery is that the
libibverbs spec file's only references to libsysfs are:

    BuildRequires: %{_includedir}/sysfs/libsysfs.h

and

    %package devel
    Requires: %{name} = %{version}-%{release} %{_includedir}/sysfs/libsysfs.h

If I look at the build report, I see:

    Executing /usr/sbin/mock-helper yum --installroot /var/lib/mock/fedora-development-i386-core-556a5fabd133ba2674379cbe88a8b01eef9c14c9/root resolvedep  '/usr/include/sysfs/libsysfs.h'
    0:libsysfs-devel-2.0.0-5.i386

    ...

    Executing /usr/sbin/mock-helper yum --installroot /var/lib/mock/fedora-development-i386-core-556a5fabd133ba2674379cbe88a8b01eef9c14c9/root install  '/usr/include/sysfs/libsysfs.h'
    warning: libsysfs-2.0.0-5: Header V3 DSA signature: NOKEY, key ID 897da07a
    
    =============================================================================
     Package                 Arch       Version          Repository        Size 
    =============================================================================
    Installing:
     libsysfs-devel          i386       2.0.0-5          core               24 k
    Installing for dependencies:
     libsysfs                i386       2.0.0-5          core               46 k
    
    Transaction Summary
    =============================================================================
    Install      2 Package(s)         
    Update       0 Package(s)         
    Remove       0 Package(s)         
    Total download size: 70 k
    
    Installed: libsysfs-devel.i386 0:2.0.0-5
    Dependency Installed: libsysfs.i386 0:2.0.0-5

and the build log says:

    Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libibverbs.so.1 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.3.2) libsysfs.so.2 rtld(GNU_HASH)

So as far as I can tell, the correct version of libsysfs is being
built against, and the build system is coming up with the right
Requires line.  

So why do I keep getting those automated emails??

Thanks,
  Roland


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]