[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Handling optional package requirements



Hi.

Given that RPM does not (yet) support Suggests: tags or something like this
I'd like your opinion on a single case.

I maintain fwbuilder in FE, a tool to manage and create firewall rulesets.
fwbuilder can work with a version management system (RCS) to create
versioned rulesets. Using version control is optional, and fwbuilder works
just fine without it. However, it always offers version control, even if
RCS is not installed. Trying to enable version control without RCS being
installed results in a not-too-helpful error message.

So: should fwbuilder Require: rcs? I have not received any bugs about this,
but noticed it myself while using fwbuilder.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]