[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

claws-mail, libetpan (was: Re: Summary - Broken dependencies in Fedora Extras - 2007-02-15)



On Thu, 15 Feb 2007 13:28:55 -0000, Fedora Extras repoclosure wrote:

>         claws-mail - 2.7.2-1.fc7.i386    (6 days)
>         libetpan - 0.49-1.fc7.i386    (6 days)

> ======================================================================
> Broken packages in fedora-extras-development-x86_64:
> 
>     claws-mail-2.7.2-1.fc7.i386  requires  libdb-4.3.so
>     libetpan-0.49-1.fc7.i386  requires  libdb-4.3.so

This is odd. First of all, libdb-4.5.so seems to be available since Dec
4th.

And claws-mail need not link against libdb at all, since it is libetpan
that links against it and BuildRequires db4-devel. It's libetpan-config
which returns the libraries it is linked against,

$ ./libetpan-config --libs
-L/usr/lib -letpan -pthread -lssl -lcrypto -ldb-4.3 -lsasl2

and which causes apps to link against them, too.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]