[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dev fs LABEL=/



On Tue, 2003-10-07 at 09:02, Arindam Dey wrote:
> On Mon, 2003-10-06 at 07:46, jdow wrote:
> > From: "Mike Watson" <mikew crucis net>
> > > > I tried to compile a custom 2.4.22 kernel - when I boot it I get a
> > > > VFS kernel panic error saying it cannot open root device LABEL=/ or
> > > > 00:00. 
> > [snip other problem desc]
> 
> > Have you tried editing /etc/fstab to change the format from
> > "LABEL=/" to "/dev/hda2" or the like?
> 
> On the above solution I wanted to ask one question. On RedHat systems if
> I download a vanilla kernel and compile and install it successfully why
> do I have to change the fstab format to /dev/hdX? Why can't I let it
> remain in the LABEL=/** format. I personally don't have any issues with
> the LABEL format but everytime I install a vanilla kernel either I have
> to pass the root=/dev/hdX note it does not work if I pass root=LABEL=/
> like redhat does. I just wanted to know why? It has just a minor
> irritation which I could not understand.

sct already answered that one:

> Sounds like you need an initrd.  The kernel can't parse mount labels,
> but if you use an initrd the real root fs gets mounted by user space
> instead.
> 
> --Stephen

Nils
-- 
     Nils Philippsen    /    Red Hat    /    nphilipp redhat com
"They that can give up essential liberty to obtain a little temporary
 safety deserve neither liberty nor safety."     -- B. Franklin, 1759
 PGP fingerprint:  C4A8 9474 5C4C ADE3 2B8F  656D 47D8 9B65 6951 3011

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]