[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: CUPS nightmare



On Sat, 25 Oct 2003, nosp wrote:

> On Sat, 2003-10-25 at 16:29, Bill Johnson wrote:
> > Printing from laptop worked fine under previous config (Redhat 7.3 was on 
> > previously on server, and printing was via lpd), but I cannot get printing 
> > to work from laptop now.
> > 
> > Cups is installed on server and printer works fine when printing from 
> > server.  
> > 
> > Printer has been configured on laptop every possible way, but will not 
> > print.  Have read google posts, howtos, and cups docs for 2 days, but 
> > nothing works.
> > 
> > nmap shows port 631 on server, but DOES NOT show it on laptop.  Firewalls 
> > are completely off on both laptop and server.
> 
> Can you telnet from the laptop to port 631 of the server?   Do you have
> cups installed on the laptop?  Can the laptop tell you the status of the
> server print queue (run lpq -P<printqueuename> on the laptop)?  Are you
> seeing any error messages on the server in /var/log/messages or
> /var/log/cupsd/errorlog?
> 

No I cannot telnet to port 631 - here is result of my attempt:

[bill dhcppc1 bill]$ telnet NEC:631
NEC:631: Unknown host
[bill dhcppc1 bill]$


Yes, I have cups installed on both laptop and server.  I can restart on 
both systems via /sbin/service restart cups.  I can manage the cups app in 
both systems via the web interface - http://localhost:631

No I cannot tell the status.  In an earlier post, I mentioned that I have 
2 queues defined now on the server (HP841C and HP841C_SHARED), and I have 
one on the laptop (HP841C_LOCAL).  Here is the result of the lpq command 
on each:
[bill dhcppc1 bill]$ lpq -PHP841C
Printer: HP841C localhost - ERROR: spool queue for 'hp841c' does not exist 
on server localhost.localdomain
   non-existent printer or you need to run 'checkpc -f'
[bill dhcppc1 bill]$ lpq -PHP841C_LOCAL
Printer: hp841c_local localhost - ERROR: spool queue for 'hp841c_local' 
does not exist on server localhost.localdomain
   non-existent printer or you need to run 'checkpc -f'
[bill dhcppc1 bill]$ lpq -PHP841C_SHARED
Printer: HP841C_SHARED localhost - ERROR: spool queue for 'hp841c_shared' 
does not exist on server localhost.localdomain
   non-existent printer or you need to run 'checkpc -f'
[bill dhcppc1 bill]$

Obviously, I have something messed up.  Any suggestions where else to 
look?  Your advise and expertise and greatly appreciated.  I'm always 
amazed at the quick responses I get from these newsgroups.

Regards,

Bill Johnson





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]