[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ATI RADEON 9600



Just to Follow Up.
Today made a comment about NOT being able to use Fedora "out of the box"
> RE: transition from red hat 9 to fedora
Having to install the drivers from ATI's website.
Not having to rpm -e --nodeps XFree86-Mesa-libGLU and install the the driver from ATI's website. Well I am very impressed with Mike Harris work on XFree86 and not watching DVD's on Saturday or Sunday. If you had a paypal account I would buy you a BEER.


So today I did all the updates. Then made sure that I installed all the XFree86 packages that I needed. And I have them all. I then removed the ATI that I had installed.

rpm -e --nodeps fglrx-glc22 to remove the old .rpm from ATI's website http://ati.com/support/drivers/linux/radeon-linux.html

I reinstalled the .rpm's that I had downloaded the XFree86 files that I was missing, the Mesa*.rpms, I unistalled per ATI's README. I was using my Redhat modified kernel that I rebuilt to enable NTFS support for my work files. I JUST COPIED THE MAKEFILE FROM /boot TO .config /usr/src/linux* THEN WOULD make xconfig AND ENABLE NTFS. THAT IS ALL I WOULD EDIT/CHANGE FOR NOW. The makefile would always rename it .custom so when I would make modules make modules_install it would not change the existing modules build.

I BACK UP XFCONFIG-4 AND ERASE XFCONFIG-4

So when I rebooted today into the newest kernel, I got a prompt to config my Radeon card I enable it that is the prompt. Then on to XFree and so I chose the Video Card Radeon 9600 and the Monitor Viewsonic PF790 and Video Setting 1280X1024. It continues to GREAT fedora login. I login and as Gnome starts to load _CRASH_ the machine just hangs.

REBOOT

I go back through load all the kernels that I have the default kernel that have been through Fedora core I have kept around just out of laziness. So I load up the old default I believe foo.2110.nptl

Login screen login/password Gnome starts loading.... STOP! It hangs mouse is dead machine is dead no CNTRL-ALT-DEL either. HUNG.

REBOOT

Load back in and CNTRL-ALT-BACKSPACE 6 times to break out of the GDM. Console is just fine. PROMPTED that X will restart in 2 minutes. I delete XFConfig to buy sometime. Crazy enough it doesn't detect the card. Used a VESA driver edited the PROMPTS from redhat-config-xfree (KILLER APP BTW) Select Radeon 9600 and Viewsonic PF790 and it writes the file /etc/X11/XFconfig of course and restarts X (GREAT JOB REDHAT). Login and start up as soon as the Gnome Dialog comes up no Icons stream across and HUNG!

REBOOT

No matter what I try I cannot get it to work this way.

So here is what I have tried:

insmod radeon
insmod radeonfb

The VESA driver works fine and I can use that but then I have 800x600 display and like 50HZ of refresh. So you know that I didn't buy the card for that :-)

What on earth can this be I wonder? My machine is broken.

I figure remove the MESA* stuff reload the glrx-glc22*rpm from ATI and just try again.

SYSTEM:
MB: ASUS A7N8X - Recent Bios Updates
RAM: 512MB DDR (2x256)
HD: WD 80GB
CDR: YAMAHA
CD: TEAC
VIDEO: ATI RADEON 9600 256MB RAM AGP 8X

Default Fedora Kernal(s) and XFree.

Thank you,
Ryan Zygar



NOTHING HELPS there.

On Oct 28, 2003, at 5:18 PM, Ryan J. Zygar wrote:

updated Fedora Core system with the ATI Radeon 9600 and drivers from the
ATI website for XFree86 4.3 after every kernel update I run the .rpm
file from ATI's site to make sure that it is installed correctly. I have
to as the ethernet card on the ASUS A78X has the nforce2 chipset and the
onboard ethernet takes a driver from the website at nvidia.com so I do
it for both the ethernet and the ATI video card. Well since the dawn of
this machine tuxracer has never been able to work correctly as it wants
the MESA .rpm file or something as when I remove it no OpenGL program
will run. Anyone else with this problem? The reason that it will not run
as it cannot find the libraries for OpenGL. libGLU.so.1 is removed.
If I reinstall XFree86-Mesa-libGLU-4.3.0-42 then it runs slower than
anything I have ever seen.


Please help.

Thank you,
Ryan Zygar


-- fedora-list mailing list fedora-list redhat com http://www.redhat.com/mailman/listinfo/fedora-list





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]