[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora Core 3 Update: boost-1.32.0-1.fc3



On Wed, 1 Dec 2004 17:06:42 -0600
Benjamin Kosnik <bkoz redhat com> wrote:

> Product     : Fedora Core 3
> Name        : boost
> Version     : 1.32.0                      
> Release     : 1.fc3                  
> Summary     : The Boost C++ Libraries

> ab219a6889f5fef508a2f871f3c6f9dc  SRPMS/boost-1.32.0-1.fc3.src.rpm
> 3947b4efb93eff2894a941a9e9f1bb2c  x86_64/boost-1.32.0-1.fc3.x86_64.rpm
> a4acffce297f386d13918021694cbf0b  x86_64/boost-devel-1.32.0-1.fc3.x86_64.rpm
> 8ba6983f6dc0abeeadb742586f29fb71  x86_64/debug/boost-debuginfo-1.32.0-1.fc3.x86_64.rpm
> 772adf7e46f0b47c8b00a76b37576221  x86_64/boost-1.32.0-1.fc3.i386.rpm
> 772adf7e46f0b47c8b00a76b37576221  i386/boost-1.32.0-1.fc3.i386.rpm
> 3f4731235c2f1ac3a5ccf4bba7e42c8c  i386/boost-devel-1.32.0-1.fc3.i386.rpm
> d21c9789d7067516a7c185e9bfc145f0  i386/debug/boost-debuginfo-1.32.0-1.fc3.i386.rpm


Hi Benjamin,

FYI:

Updating via "yum update" results in boost-devel package being
REMOVED from a complete installation.  The existing boost-devel-1.31.0-9
is removed but the new boost-devel-1.32.0-1 is NOT installed.

It can be installed by a "yum install boost-devel" afterwards.

It probably has something to do with these Obsoletes you put in
the packages and the way rpm/yum works:

Obsoletes: boost <= 1.31.0
Obsoletes: boost-devel <= 1.31.0
Obsoletes: boost-doc <= 1.30.2
Obsoletes: boost-python <= 1.30.2

	greetings,
	Rob van Nieuwkerk


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]