[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Samba smbmount failing to observe uid/gid



I have noticed several e-mails (on this and other lists) concerning the use of uid/gid with smbmount
not working on FC3. i.e. if I smbmount a samba share, the uid given by a directory listing is the
uid that the files have on the samba server, not the uid given with the smbmount command. The
effect when rewriting a file via the mount point is that the transfers 'hangs' for several seconds and
eventually returns an I/O error, presumably as a permission problem but it is not reported as such.
The following is in syslog (/var/log/messages):


Nov 29 13:48:07 jrw kernel: smb_trans2: invalid data, disp=0, cnt=0, tot=0, ofs=0
Nov 29 13:48:37 jrw kernel: smb_add_request: request [36270c80, mid=18] timed out!
Nov 29 13:49:59 jrw kernel: smb_trans2: invalid data, disp=0, cnt=0, tot=0, ofs=0
Nov 29 13:50:29 jrw kernel: smb_add_request: request [36270c80, mid=28] timed out!
Nov 29 14:01:01 jrw crond(pam_unix)[4865]: session opened for user root by (uid=0)


This does not occur on RH9 and RH8. I have tried all three released FC3 kernels (667, 678, and 681)
and both versions of samba released with FC3 (3.0.8 and 3.0.9)


The samba mail archive for October makes reference to a patch which was (to be) included in
2.6.9-rc4-mm1 but I cannot see a corresponding reference in the change logs for 2.6.9 or
2.6.10-rc2 or 2.6.10-rc2-mm4


Can anyone point me to the status of this problem? My knowledge does not take me that far.

Thanks in advance

John Whitley



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]