[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC3 can't find LVM volumes, boot fails, kernel panics



On Fri, 2004-12-03 at 17:29 -0500, Deron Meranda wrote:
> Okay, with some investigative work and some pointers from Fred, this
> now appears to be an issue with the megaraid kernel module being
> missing.  In particular the megaraid_mbox and megaraid_mm modules are
> not in the boot kernel image.  Both of those modules are loaded by the
> rescue CD, which explains why I can see all the filesystems when
> booting from rescue, but not the on-disk image.
> 
> However, I've tried to do a mkinitrd to force them and it complains.
> 
>   # mkinitrd -v -f --with=megaraid_mbox /boot/initrd-2.6.9-1.667.img 
> 2.6.9-1.667
>   ...
>   No module megaraid found for kernel 2.6.9-1.667, aborting.
> 
> What's the trick now to get the needed *.ko files into the initrd image?

One option is to unpack the initrd that gets built by mkinitrd, add the
required modules, modify the init script to reflect your changes, then
pack it back up replacing the faulty initrd.

I never tried this so I don't know if there is anything else done by
mkinitrd that would be required. You could try it and see what happens.

-- 
C. Linus Hicks <lhicks nc rr com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]