[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ACPI and kernel 2.6.9-1.6.FC2



Efthym wrote:
On Fri, 03 Dec 2004 07:27:29 -0500, Jim Cornette <fc-cornette insight rr com> wrote:

Wong Kwok-hon wrote:

On Thu, 2 Dec 2004 17:36:25 -0600 (CST), Satish Balay <balay fastmail fm> wrote:

On Fri, 3 Dec 2004, Wong Kwok-hon wrote:




On Thu, 02 Dec 2004 14:15:48 -0500, Efthym <efthym gmx net> wrote:

Hi all,
I am running FC2 on an IBM T21. I updated from the 2.6.8-1.521 to
2.6.9-1.6.FC2 kernel. Now the computer doesn't shutdown and stays at the
"system halted". This used to work with the 2.6.8. I still haven't tried
suspending which again used to work fine.
Has something changed in the new kernel ?



Seem that something has changed in 2.6.9 because it is not a problem in 2.6.8
Because I can't poweroff the machine even the faq or other option
sugguested apm=off acpi=off.... etc.


Why use 'apm=off?. I use 'acpi=off' (i.e apm=on) - and no problems
with shutdown on a T40/FC3. But things could be different on T21/FC2.

Sorry, I don't know why and some people tell me it work and one new
answer to me is acpi=on and hasn't test it work or not...
I wonder why the above off option works in others but not work in mine....
Ringo



This issue needs to be resolved. I use acpi=on and the shutdown used t work with eqarlier kernels. For now, I just hold in the power button to turn off the computer on shutdown.


What broke it and why it is taking so long for a remedy is beyond my understanding.

Jim


I agree Jim. What machine you have the problems on? Is the situation the same as mine ?(problems statred after 2.6.9 kernel?)

Best Regards

Efthym


The problem happened on an HP ze4315us computer during the same time that I applied updates from HP to the machine.


 BIOS Information
                Vendor: Phoenix Technologies Ltd.
                Version: KAM1.58
                Release Date: 03/17/2004
                Address: 0xE4680
                Runtime Size: 113024 bytes
                ROM Size: 512 kB

At first onset of the shutdown problem, I thought that applying the upgraded BIOS was responsible for the power-off breakage. Afte reading the list messages, it was more universal.

Since the problem happened from one version to the next version, it probably would be possible to backtrack the tral to the acpi power-off call.
I haven't tried the earlier kernels to see if the problem is gone with earlier kernels.


Jim



--
Noone ever built a statue to a critic.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]