[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC3 Graphical Install and Boot Problems



Richard Duncan wrote:
This is a double send to correct me forgetting to change the subject line on the last email...sorry about that.

On Dec 4, 2004, at 6:42 PM, Richard Duncan wrote:

Tried changing driver to "vesa", same result. I get a very scrambled screen (I can barely make out the "Fedora Core" logo a couple times across the middle of the screen) at all color modes and resolutions. I also tried getting the proprietary ATI drivers on a flash drive and rpm'ing them in, just to see if even in 2-D the fglrx driver would work, but same result once again. Would changing the VendorName and BoardName have an effect, or are those just to make the configuration keep track of what kind of board you're using so you can access that info later?

I had trouble back in RH9 getting the DVI output on my old nVidia card working right, but haven't had any trouble since until I tried upgrading to FC3. Could it be the new xorg not liking my setup? The Xorg setup that went in FC2 didn't give me any trouble though.


Date: Sat, 04 Dec 2004 07:22:53 -0600
From: Randy <toucan tropicalrain us>
Subject: Re: FC3 Graphical Install and Boot Problems
To: For users of Fedora Core releases <fedora-list redhat com>
Message-ID: <6 2 0 14 0 20041204072137 01d5da90 192 168 0 2>
Content-Type: text/plain; charset="us-ascii"; format=flowed

At 11:03 PM 12/3/2004, you wrote:

Well finally after getting it to boot in runlevel 3 I was able to
modify inittab to always do that.  I've narrowed the problem down to
the radeon kernel driver.  If I go into xorg.conf and change the driver
to vga, I can get X to start properly and display things mostly right,
but with oddity: it only works in 8-bit color mode (since that's
apparently all vga supports), and no matter resolution I set it to, I
get this 640x480 screen "zoomed" in on the upper left hand corner of
the screen (i.e., only showing the upper left quarter of the desktop).
Its odd that the kernel radeon driver won't work, since it did for me
in FC2.

New problem. Any new ideas anyone?


Try the VESA driver? I had to change mine also.

/etc/X11/xorg.conf

Section "Device"

Section "Screen"
#       Driver      "via"
#       BoardName   "S3 UniChrome"
         Identifier  "Videocard0"
         Driver      "vesa"
         VendorName  "Videocard vendor"
         BoardName   "VESA driver (generic)"
EndSection




I had similar problems trying the vesa driver on an 815 video card. (scrambled screen). Could the falure be similar to the i810 causing the scrambling? (needed to add option noaccel to xorg.conf.)



Since your card states that it is an s3 Unichrome, have you tried using the s3 or s3virge drivers?


Rough ideas is all I can think of. Have you read man via for different options using the via driver?

Jim

--
When speculation has done its worst, two plus two still equals four.
		-- S. Johnson


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]