[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum dependency problem



On Tue, 7 Dec 2004, Bernd Radinger wrote:

> On Mon, 06 Dec 2004 22:35:28 -0600, Andrew Konosky
> <TerranAce007 comcast net> wrote:
> > I am trying to install DVDRip via yum. VCDImager is a dependent, but
> > also requires two libraries that I don't have, so I keep getting the
> > following error. Where can I get these so that I don't have to compile
> > everything from source?
> > 
> > I can't seem to find libcdio or libiso9660 anywhere for FC3, or even for
> > any Fedora version.
> 
> both would be in Fedora.US which is missing in your conf, see
> http://rpm.livna.org

Actually fedora.us is missing for FC3, so he is right there is no libcdio 
or libiso9660 for FC3.

If you use Smart in this case, Smart will simply know that vcdimager has 
unmet dependencies and will propose not to use this version of vcdimager, 
but an older one that does not require libcdio or libiso9660.

Isn't that what a package manager ought to do ? Make it easy for you to 
install packages, despite the fact that there are unmet dependencies.

Apt would handle this better too, althought only Smart would be smart 
enough to downgrade rather than to fail to continue with the rest of the 
transaction.

PS There's an older vcdimager shipped by freshrpms and my repository that 
would have worked but is not considered by Yum in this case.

Executive summary: use smart :)

--   dag wieers,  dag wieers com,  http://dag.wieers.com/   --
[all I want is a warm bed and a kind word and unlimited power]


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]