[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Why is it that ssh with X11 auth forwarding fails -sometimes- on FC[23]?



On Wed, 2004-12-08 at 21:47 -0500, Deron Meranda wrote:
> On Wed, 08 Dec 2004 10:14:08 -0800, Dan Stromberg
> <strombrg dcs nac uci edu> wrote:
> > However, I'm finding that while I can (mostly?) reliably forward xauth
> > data and $DISPLAY from an RHEL 3 host to AIX 5.1, Solaris 8 and others,
> > it only works with Fedora Core 2 and Fedora Core 3 -some- of the time.
> 
> Is your FC3 system the ssh client or the ssh server?

The FC3 host is the sshd server.  Same for FC2: the sshd server.

> Have your tried using the -v option to ssh?  Or multiple -v -v -v
> options to get even more verbose output.

Yes.  It seems to say everything is fine, but then it still doesn't work
most of the time.

> In what manner does it "not work".  Does the ssh itself fail to
> connect?  Is the DISPLAY not getting set?  Do the windows just never
> appear?  Or is there an actual X11 protocol error someplace?   Please
> provide more details.

As suggested above:

$DISPLAY is set.

xauth in some form or other is getting passed.

I didn't previously mention:

I can telnet to the port that $DISPLAY indicates: n+6000.  The
connection is accepted.

However over half the time:

tesuji-strombrg> xterm
X connection to tesuji.nac.uci.edu:12.0 broken (explicit kill or server
shutdown).

Yes, I have X11UseLocalhost=no.  This makes it easier to pass xauth
creds across su/gsu/sudo.

Thanks!

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]