[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: editing fstab file ??



On Sun, 12 Dec 2004 12:45:33 -0500, C. Linus Hicks <lhicks nc rr com> wrote:
> On Sun, 2004-12-12 at 17:15 +0000, spamse wrote:
> 
> 
> > > > i would like to mount my second hard drive
> > > > it doesn't show up in the mnt folder
> > > > any help would be great
> > >
> > > You need to create a folder under /mnt before mounting drive eg:
> > > /mnt/disk2 and then you mount /dev/hdx /mnt/disk2
> > >
> > I have created a directory in /home that I have been manually mounting
> > a shared fat32 drive to each time I boot. Would I be better off
> > mounting it to a folder in /mnt?
> 
> "Better off" is subjective. It depends on what you want to achieve. If
> you care about standards see:
> 
> http://www.pathname.com/fhs/
> 
> > Also, I added a line to /etc/fstab to mount the drive, as I wanted it
> > to mount automatically on boot, but this line does not seem to get
> > executed (I was following instructions from a Red Hat site). Is this
> > the right place to be putting the mount statement?
> 
> If you want it mounted at system boot time, I can think of two reasons
> right away why it won't happen. Except for the root partition,
> partitions are mounted in the order in which they appear in fstab. So
> for instance, if /home is a separate partition and it gets mounted after
> your fat32 partition gets mounted, it won't work. Also, any partition
> specified with option "noauto" will not get mounted during boot. Using
> the "defaults" option does imply "auto".
> 
> If it's none of the above, have you tried looking
> through /var/log/messages to see if any errors are showing up during
> mounting partitions?
> 
> By the way, while this is related to the original question, I noticed
> that you essentially hijacked an existing thread to ask a different
> question.
> 
> ******************************************************************************
i tried to mount the hard drive and i get this message 
[jim My_World ~]$ mount /dev/hdb1
mount: can't find /dev/hdb1 in /etc/fstab or /etc/mtab
[jim My_World ~]$ 

i opened the fstab file using   
[jim My_World ~]$ vi fstab

the file is empty
the man pages are making me more confused 
or should i be opening ther fstab file under root ?  
 
> 
> 
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list
> 


-- 
James Lawrence
NY


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]