[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: More broken yum dependencies....



Andrew Konosky said:
[snip]
> freshrpms-: ################################################## 2622/2622
> dries     : ################################################## 603/603
> dag       : ################################################## 1389/1389
> livna-stab: ################################################## 112/112
> freshrpms-: ################################################## 336/336
> atrpms-sta: ################################################## 584/584
> fedora-bas: ################################################## 2622/2622
> freshrpms : ################################################## 452/452
> fedora-upd: ################################################## 336/336

You are trying to use livna, but not fedora.us...

http://rpm.livna.org/configuration.html

"rpm.livna.org is not a standalone repository. You must use must use
rpm.livna.org with the fedora.us repository."

> Error: Missing Dependency: libasound.so.2(ALSA_0.9.0rc4) is needed by
> package pwlib

Since pwlib isn't in the package update set, I'm going to say that the
problem is that whatever provides the libasound.so.2(ALSA_0.9.0rc4) is
trying to be updated and breaking pwlibs (and the others).

On a default install this is provided by alsa-lib-1.0.6-5.  With your mix
of repos it is hard to tell.  It looks like it should be provided by
libasound2.i386 from atrpms, which is getting pulled in.  Hmmm.

[snip]
> Error: Missing Dependency: /etc/yum.conf is needed by
> package yum

atrpms chooses to package yum.conf seperate from yum.  Not sure why the
package the provides it isn't getting pulled in (unless you have excluded
it).  IIRC there was some talk of a yum issue with some file deps, but I'm
not seeing it in yum's bugzilla right off.

> Error: Missing Dependency: libFLAC++.so.2 is needed by package
> k3b

This appears to be provided by Fedora Core's flac package, but not atrpms
flac package.

> Error: Missing Dependency: libFLAC.so.4 is needed by package
> vorbis-tools

Ditto

> Error: Missing Dependency: libavcodec.so is needed by package
> transcode

Not sure about this one.  I didn't look too hard, but I would guess that
it is similar to the others.

-- 
William Hooper


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]