[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel Pro 2200BG wireless + WPA-SPK issue?



On Mon, 2004-12-20 at 08:24 +0100, Roger Grosswiler wrote:
> Madhan Premkumar schrieb:
> [snip]
> > But that is without security, ie
> > router is open to all. But when i set my router to WPA-SPK security, I
> > could not connect thereafter. I dont know whether Intel pro 2200BG driver
> > support WPA-SPK or not.
> [/snip]
> 
> Hi Madhan,
> 
> I have the same issue using a D-Link DWL-G650+ with ndiswrapper. This 
> works quite well, except two issues:
> 
> - freezing (think is because of 4-k-stack)
> this is resolvable with some kernels using the 16-k-stack from linuxant
> 
> - WPA
> as this d-link-thing never wanted to work well with my barricade under 
> wep, i used wpa - this works well under windows. in conjunction with 
> linux/ndiswrapper (or perhaps even your card) i installed the 
> wpa/wpa2/ieee802.1x-supplicant from here: 
> http://hostap.epitest.fi/wpa_supplicant/
> 
> so, all i had to do is installing ndiswrapper (my card has been 
> recognized on boot-up *yipieeeeeeeeeeeeeeee*), installing ndiswrapper 
> and the supplicant.
> 
> All you have to do in the supplicant-config is creating a file called 
> .config, containing:
> 
> CONFIG_DRIVER_NDISWRAPPER=y
> 
> and then do make. copy the executables whereever you want (...and 
> whereever you gonna find them again...)
> 
> afterwards, create (e.g. in /etc/ a file for your wpa-config), the name 
> doesn't matter, and i have the following content:
> 
> 
> network={
> 	ssid="home"
> 	scan_ssid=1
> 	key_mgmt=WPA-PSK
> 	psk="very secret passphrase"
> }
> 
> shouldn't be a problem, as i just use wpa-psk on my smc 2804wbpr-g 
> barricade...
> 
> but it doesn't yet work, i let you know, when i get it working.. ;-)
> 
> 
> Just wrote this, that you perhaps get an idea...
> 
> Roger
> 

With my laptop I am using an AirLink model AWLC3025 802.11g pcmcia card
with ndiswrapper.

I have nothing special loaded except those items specified by the
ndiskwrapper page for configuration.

modprobe.conf contains 
    alias wlan0 ndiswrapper
    options ndiskwrapper if_name=wlan0
(Note that with these two lines you can give the adapter any interface
name you choose.  I left it at default.)

/etc/sysconfig/network-scripts/wlan0 contains
   DEVICE=wlan0
   IPV6INIT=no
   ONBOOT=no
   USERCTL=yes
   PEERDNS=yes
   GATEWAY=
   TYPE=Wireless
   BOOTPROTO=dhcp
   HWADDR=
   NETMASK=
   DHCP_HOSTNAME=my.preferred.hostname
   IPADDR=
   DOMAIN=
   ESSID=myessidname
   MODE=Managed

I am using WEP encryption so I also have /etc/sysconfig/network-
scripts/keys-wlan0 which contains a single line with
   KEY=<the 26 digit key that matches the key in my access point>

ndiswrapper loads at boot, and the card is activated as soon as I plug
it in.  It has worked flawlessly since I installed ndiswrapper with the
windows drivers for that card.

The machine was freezing with the stock kernel, but I installed the 16k
kernel from linuxant and that stopped the freeze issue.

Full configuration information was available from the ndiswrapper page
and it worked on first try.

YMMV


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]