[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Which is my USB device?



Christopher J. Bottaro wrote:

Gustavo Seabra wrote:



Christopher J. Bottaro wrote:



I installed FC3 on my laptop and it has one USB port.  I plugged in my
digicam in that USB port and I want to mount it as a USB file system.  The
problem is that I don't know which device the USB port is associated with.
On my home computer, it is /dev/sdx, but I don't see those options in
/dev/ on my laptop.

That leads me to a general Linux question.  How are devices assigned?  One
of my computers assigned /dev/sdx to everything, hard drives, optical
drives, USB ports, etc.  Another computer assigned /dev/hdx to my hard
drives and optical drives, but /dev/sdx to my USB ports.

I also have a KDE question.  Is there anyway to automatically mount my
camera as a USB file system when it is plugged into my laptop?  Is there a
way to detect that it is a camera?  I don't want to mount *every* USB
thing plugged into my laptop as a USB filesystem...

Thanks for the help.



   Take a look at 'man fstab-sync'. There you'll find instructions of
how to define a *.fdi file and put it into
/usr/share/hal/fdi/95userpolicy/ so that it will recognize your devices
practically anyway you want it.

In my case, I have a camera and a usbstick. The usbstick was being
recognized with a weird name, and the camera as 'usbstick'. Both
appeared in /media when inserted, then I just had to mount them. To have
them appearing with the right names, I made a fdi file for each
(camera.fdi & usbstick.fdi) that redefined the names of each. Now, using
KDE, I could put an icon in my desktop for each of these. When I
double-click the icon, it automatically mounts the device (assuming it's
connected, of course) and opens Konqueror with it.



Cool thanks for the pointer. I'm actually on vacation right now and just want to get some videos off my digicam...I don't really have time to figure out this fstab-sync stuff. I just need to know which device the dang USB port shows up as in /dev/...any ideas? =/

Thanks again.



I'm not very knowledgeable on that, but I can tell what worked for me: look into the /media folder (ls /media). Usually (nothing connected) I'd see only cdrom/ and flppy/ . Then, plug in the camera, wait a bit (~30 sec max) then take another look there. There *should* be another point, that in my case was usbstick/ (even though it was a Gateway digital camera). Than all you have to do is mount whatever it is (mount /media/_whatever_shows_), and it should work. Note that it worked for me because my camera is mountable as an external (USB) HD, but I don't know which camera is yours, so I can't guarantee anything. However, based on your initial description, I assume it can be mounted as a USB HD.

If it doesn't work, may your camera really needs a driver. In that case, you could try to tell KDE to look for your camera: Just plug the camera in and go to Control Center -> Peripherals -> Digital Camera. There you may be able to add your camera, provided it is in the database (which is pretty large).

I hope that helps, and enjoy your vacation!

--
--
----------------------------------
Gustavo Seabra - Graduate Student
Chemistry Department
Kansas State University
----------------------------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]