[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: firefox and java



On Tue, 2004-12-21 at 17:22 -0500, Claude Jones wrote: 
> Gerhard Magnus wrote:
> ||| If you are using Firefox, you would want to put the link in
> ||| the "firefox/plugins" directory... not mozilla's plugin
> ||| directory. 
> | 
> | OK, makes sense.  The closest I could find to "firefox/plugins"
> | was the directory /usr/lib/firefox-0.10.1.  I created a
> | subdirectory "plugins" and put the link
> | to /usr/java/jre1.5.0/plugin/i386/ns7/libjavaplugin_oji.so
> | there.  I still keep getting these perplexing firefox messages
> | (now from several webpages.)
> | 
> 
> You got close. Look again and see if you see
> /usr/lib/firefox-1.0/plugins
> That's where you have to put the link... I just went through this.

Maybe this will all seem simple eventually but for now it's like trying
to thread a needle in very dim light.  The "Jpackages" webpage is a
little too advanced for me at this point.

(1) I had assumed packages keep their names after they're installed, but
this doesn't seem to be the case.  Why does j2re-1_4_2_06-linux-i586.rpm
turn into 2re-1.4.2_06-fcs and jre-1_5_0-linux-i586.rpm become
jre-1.5.0-fcs?  When I run "rpm -Uvh" on either of the origin rpm's I'm
told that the corresponding "fcs" files are already installed.

(2) I now have two java directories under /usr/java: j2re1.4.2_06 and
jre1.5.0.  Can someone just tell me which one works with Firefox 1.0?
Does either?  I believe all I need is the runtime environment for the
web application I have in mind, but the Firefox "plugins" section (under
preferences-download) still doesn't show any java installed.

(3) I need to put a link in /usr/lib/firefox-1.0/plugins -- but which
one?  Under the /usr/java/j2re1.4.2_06/plugin directory I have ns4,
ns610, and ns610-gcc32.  Under /usr/java/jre1.5.0/plugin there's ns7 and
ns7_g to choose from.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]