[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: firefox and java



On Tue, 21 Dec 2004 17:22:12 -0800, Gerhard Magnus
<magnus agora rdrop com> wrote:

> (1) I had assumed packages keep their names after they're installed, but
> this doesn't seem to be the case.  Why does j2re-1_4_2_06-linux-i586.rpm
> turn into 2re-1.4.2_06-fcs and jre-1_5_0-linux-i586.rpm become
> jre-1.5.0-fcs?  When I run "rpm -Uvh" on either of the origin rpm's I'm
> told that the corresponding "fcs" files are already installed.
> 

You need to ask the person who created the package.

> (2) I now have two java directories under /usr/java: j2re1.4.2_06 and
> jre1.5.0.  Can someone just tell me which one works with Firefox 1.0?
> Does either?  I believe all I need is the runtime environment for the
> web application I have in mind, but the Firefox "plugins" section (under
> preferences-download) still doesn't show any java installed.
> 

You do not need both.  I recommend that you remove the 1.4.2 jre.

Get the versions of jre installed on your system by typing:

# rpm -qa | grep jre

Remove the one you do not want by typing:

# rpm -e <name of rpm-package from above>

Tip: Use your mouse to highlight the name of the package, right-click,
select copy,  right-click, and select paste to insert the data in the
line above.

> (3) I need to put a link in /usr/lib/firefox-1.0/plugins -- but which
> one?  Under the /usr/java/j2re1.4.2_06/plugin directory I have ns4,
> ns610, and ns610-gcc32.  Under /usr/java/jre1.5.0/plugin there's ns7 and
> ns7_g to choose from.
> 

Answers are provided at http://plugindoc.mozdev.org/linux.html

-- Kam Leo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]