[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: previous problem sort of resolved



On Wed, 22 Dec 2004 22:05:57 -0500, Jim <lawrence jim gmail com> wrote:
> On Wed, 22 Dec 2004 19:58:42 -0600, Jonathan Berry <berryja gmail com> wrote:
> > Did you get this problem solved?  The last message in that thread that
> > I see from you says you were going to bed :).  Let's not mix the
> > threads, so reply to that thread with more info if you have it.  I

Oh well, I tried.  I'm sending this to the list.  Sorry forgot to not
send it directly to you.  Be more careful to whom you are sending
replies, especially when gmail addresses are involved : ).

> > don't think the FC2 repos in the sources file is the problem, because
> > you definitely have the FC3 kernels from your "rpm -qa kernel" output.
> >
> > Jonathan
> this some cmds  you had be try
> [jim My_World ~]$ su -
> Password:
> [root My_World ~]# cd /boot
> [root My_World boot]# ls /
> bin   dev  home    lib         media  mnt  proc  sbin     srv  tmp  var
> boot  etc  initrd  lost+found  misc   opt  root  selinux  sys  usr
> [root My_World boot]# ls -l /boot
> total 2548
> -rw-r--r--  1 root root   51271 Nov 18 15:16 config-2.6.9-1.681_FC3
> -rw-r--r--  1 root root  392464 Dec 21 21:24 initrd-2.6.9-1.681_FC3.img
> -rw-r--r--  1 root root  724204 Nov 18 15:16 System.map-2.6.9-1.681_FC3
> -rw-r--r--  1 root root 1417598 Nov 18 15:16 vmlinuz-2.6.9-1.681_FC3
> [root My_World boot]# ls -l /etc/grub.conf
> lrwxrwxrwx  1 root root 22 Jun 18  2004 /etc/grub.conf ->
> ../boot/grub/grub conf[root My_World boot]#
> 
> /etc/grub.conf ->
> ../boot/grub/grub conf[root My_World boot]#  <------ is in red

Yikes!  You really don't have a /boot/grub/ directory!  What is going
on here.  I also only see the newest kernel images in /boot/  Which
kernel are you running?  Try these three commands:
uname -a
fdisk -l
mount
cat /etc/fstab

The first will tell you what kernel you have.  The only thing I can
come up with is that you (now?) have a seperate /boot/ partition and
things have gotten confused.  Perhaps your /boot/ partition has the
original kernel and grub directory, so grub sees it fine, but the
partition is then not mounted.  You then updated the machine, which
copied the new kernel into the /boot/ directory on the main partition.
 This would explain why your grub.conf was not updated, and why you
can only boot your old kernel.  It's a long shot, maybe, but it's the
only thing I can think of.  If this is what is happening, I don't have
a clue how you got there.  Maybe something went wrong with labelling
somewhere?  If you know the details of your partitions, send those
along with the output from the above commands.

Jonathan

--
Merry Christmas!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]