[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Samba and Windows XP user share setup problems




----- Original Message ----- From: "Rick Stevens" <rstevens vitalstream com>
To: "Getting started with Red Hat Linux" <redhat-install-list redhat com>
Sent: Thursday, December 23, 2004 11:41 AM
Subject: Re: Samba and Windows XP user share setup problems



Greg wrote:
Hello y'all,
I've had to rebuild my Linux gateway server from scratch. I had the client data saved off so I didn't loose anything critical, but all of the settings and such went out the door. Since I had to re-create the thing, I started with the Fedora Core v2 and have loaded all of the patches up to today.
I've been away for a long time, but recall having received the best help from this install list. If there is another list (I didn't see a fedora-install-list), let me know and I'll move over there. Also, I seem to remember a way to configure your maillist settings, but I can't find it now. If it's still there, could somebody point it out to this dunder-head?

There's no "fedora-install-list", but there is a "fedora-list" at http://www.redhat.com/mailman/listinfo/fedora-list.


Thanks, As you can see, I'm continuing this post over here in fedora-list


OK, Problem Statement:
I have Samba 3.0.10-1.fc2 running on kernel 2.6.9-1.6_FC2. Something fails when I try to get from Windows XP (SP2 with all updates) to that share.
Activities to date: (BTW, Linux box = samba server = 192.168.1.1 = lookout. Windows XP = 192.168.1.100 = fileserver)
I have created (and re-created) both the Linux user and the samba user. I can sign on just fine with the user. My Windows XP user is the same. The user name is 'snappy'.
I have 'security = user' in the globals portion of the samba config file. I have been able to get 'security = share' to work, but I need 'security = user'. I have a directory /usr/xxx/webfolders which is set up to be a share. I have also set up a share at /home/snappy for the snappy id. I care about the former share but not the latter.
Samba is not a PDC, nor do I want it to be one at this time. I'm using peer to peer (workgroup) networking at this time throughout the shop.
I have uninstalled and re-installed samba - same failures. I have mucked around with the settings, both global and the share's, and have made no progress.
I am able to reach to the network shares on the XP box from the Linux box - and manipulate them - but not the samba shares from the XP box.
When I go to My Network Places => Entire Network => Microsoft Windows Network => workgroupname I can see the Linux box (called lookout). When I click on the lookout machine, I get dialog box stating "Connect to lookout.example.com" in the title, "Connecting to lookout" in the text area, and two input boxes labeled "User name:" and "Password:". No matter what I put in here, I just get the box back.
I've disabled both the Windows firewall and the software firewall on the XP box, and I have no firewall set up on the Linux box at all (for now).
I've set the logging to 3 on both the syslog and the samba log and find no errors at all in there. In the log that represents my XP box (192.168.1.100.log) I get the same series of messages, but no errors (that my untrained eye can detect). I've included that below.
Well, That's the opening gambit. I'd sure appreciate it if somebody can help me figure out what to try next.

Did you use smbpasswd to set up the Windows user password on Linux?


Greetings Rick, Thanks for your reply.

Yes, I had. I did it manually and with the swat tools. Same difference. No go.

I threw up my hands in the air again and reset all of the global defaults back to their default using swat's 'set default' button. Then I saved the changes and re-booted both the Linux Box and the Windows Box. I tried again and ...
It worked.


Beats me what's different. I figure you (Rick) waggled your magic fingers and set things to right. Thanks!

On further thought:
I was getting connection reset by peer messages, but they disappeared when I put on the samba patches that came out yesterday (Tuesday, Dec 22, 2004). I was still getting the failure even after putting on the patches, so I didn't think they did anything germane to my problem. But I had set everything to default (by copying in a default config file) previously as well and that hadn't worked either. I can only guess that whatever the patches fixed were part of my problem (??) and that resetting again to default settled the remaining issues. Or perhaps there were differences between the two methods I used to set things to default.


Anyway, Thanks and have a Merry Christmas & Happy New Year!

-g

<snipped log portion>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]