[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: slmodemd dead but subsys locked -SOLVED



On Sat, 25 Dec 2004, Antonio Olivares wrote:

> Dear Ronald, Matthew & all in list,
>
> Sorry for the question,
>
> --- Matthew Saltzman <mjs ces clemson edu> wrote:
>
> > On Fri, 24 Dec 2004, Ronald K wrote:
> >
> > > Thanks.. got a solution
> > > needed to stop the service altogether and then rm
> > -f /var/lock/subsys/slmodemd
> > > also added slamr to "others" in /etc/rc.sysinit
>
> Where exactly did you place the line rm -f
> /var/lock/subsys/slmodemd (Line #)?  I have tried

This is entered on the comand line to clear a stale lock file.  If you
read the startup script, you'll see that "/sbin/service slmodemd stop"
will take care of this for you.

Note that "/sbin/slmodemd start" or invoking the start script at boot
won't clear this file, and the daemon won't start if the file is in place,
so if the daemon dies without clearing its lock file, it won't start at
boot.  Clearing the stale lock file and then rebooting seems to have
worked for Ronald.

Now, Ronald seems to have it working, so perhaps he will respond
explaining exactly how he configured everything.

> again and again and have not been successful loading
> slmodemd upon boot.  I have the script in
> /etc/init.d/slmodemd that starts slmodemd at boot and
> everything loads up except that the message slmodemd
> locked just like yours.  I run system-config-services
> and just click on start in the slmodemd and slmodemd
> starts and does everything that it is supposed to.

Does /var/log/messages show anything about slamr or slmodemd when it fails
at startup?

>
> >
> > If you want to avoid modifying rc.sysinit (a good
> > idea, IMO), create the
> > script /etc/rc.modules with the appropriate modprobe
> > command.  It is
> > executed by rc.sysinit (if it exists) early enough
> > in the process that the
> > module will be loaded by the time slmodemd is
> > started.  And it won't get
> > nuked next time you upgrade initscripts.
>
> I created a script rc.modules and added the line
> alias char-major-212 /dev/ttySL0 slmar
> which is also present in /etc/modprobe.conf.  And
> still get the message that it is locked.

rc.modules is a bash script.  If you use this to load the slamr module, it
should contain

	#!/bin/bash
	/sbin/modprobe slamr

but if you have "alias char-major-212 slamr" (note the difference between
this line and yours--this is the line added to /etc/modules.conf when
using kernel-2.4) in /etc/modprobe.conf, you shouldn't need
/etc/rc.modules (or vice versa).

>
> In /etc/init.d/slmodemd the following segment of code
> loads slamr but gets the line /var/sys/locked.  Can
> you point a solution to eliminate that message from
> here?
>
> start() {
> 	cat /proc/modules | grep 'slamr' >/dev/null || {
> 	echo -n "Loading SmartLink Modem driver into kernel
> ... "
>         modprobe slamr && echo "done." || {
> 	   echo "failed."
> 	   exit -1
>           }
>         }

This looks like the Mandrake version of the startup script.  In
slmodemd-2.9.10, the basic script doesn't contain these lines.  Note that
this script also inserts the module.  You'll want only one of the
techniques--slmodemd script, etc/modprobe.conf, /etc/rc.modules.

>         echo -n "Starting SmartLink Modem driver for
> $SLMODEMD_DEVICE: "
> 	$prog </dev/null >/dev/null 2>/dev/null \
> 	    --country=$SLMODEMD_COUNTRY $SLMODEMD_OPTS
> /dev/$SLMODEMD_DEVICE &
> 	RETVAL=$?
> 	[ $RETVAL -eq 0 ] && success $"$prog startup" ||
> failure $"$prog startup"
> 	echo
> 	[ $RETVAL -eq 0 ] && touch /var/lock/subsys/$prog
> 	return $RETVAL
> }

> >
> > Alternatively, you could build slmodem using the
> > ALSA driver.  I had it
> > working in FC2 with no problems, and no extra
> > modules needed.
>
> In Fedora Core 2 the script works to perfection
> without a hiccup.  No problem whatsover.  I made it
> work on a friends computer which runs Fedora Core 2.
>
> > (Haven't tried in FC3 yet.)
> >
>
> This is the only thing that is holding me back.  If I
> can correct this, my major problems will have been
> solved.  Upon getting it to work, I'll make sure to
> help others whenever I can.  I appreciate your help
> and suggestions.

If this works with kernel-2.6.* in FC2, then I would suspect something
having to do with udev.  Reading the slmodem readme, it's not clear what
creates the devices that are needed by the modem daemon.

As I recall, you can get the modem up and fully functional, just not at
boot.  You might try the following:  Once you have everything operating
correctly, copy /dev/slamr* to /etc/udev/dev.  Then the devices will be
created at boot.

>
> Thank you very much,
>
> Antonio

-- 
		Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]