[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Connecting to Wireless Networks



Rick Bilonick wrote:

I asked about connecting to public wireless networks before but did not get much input. I am using RH 9 on a laptop. I have no problem connecting to my home wireless network. I used the gui network program to do the configuration. It uses wep in managed mode and dhcp. It was simple to do.

But connecting the same laptop to other wireless networks has never worked. No matter how I try to configue using the gui interface, I never get a connection, regardless of whether the network has an essid and wep or not. The green led on the wireless card (D-Link 650 - prism 2 chipset) always flashes (it is solid when it connects). (I have no trouble connecting the laptop to wired networks in hotels.)

So I have recently tried using iwconfig. I open a shell as root and enter commands like:

/sbin/iwconfig eth1 key off
/sbin/iwconfig eth1 mode Managed
/sbin/iwconfig eth1 essid any
/sbin/ifconfig eth1 up
/sbin/dhclient eth1

if I the network doesn't use wep. If the network requires an essid and/or wep, I include the information and modify the above commands apropriately.

When I use these commands, the card connects to the network (the green light stays on without blinking) and the icon on the panel shows a connection. If I do a "netstat -r" I can see the gateway's IP address. I can ping this IP address and my computer at home. But I can't do much else. DNS doesn't work and I can't find any web pages. The web browser is supposed to go to a login web page but I can never get to it. My understanding was all I needed was an empty "dhclient.conf" file and I would get a lease and the domain name server address. I do get a lease but I don't think DNS is working. I can't ssh or telnet anywhere. (Yet I can ping as described above.)

I have tried this on two different wireless networks (Barnes & Noble and a university library). I connect but can't do anything other than ping some IP addresses. I cannot get to the login web pages or any other web pages. What else do I need to do? Something else must need to be configured. Any insights would be greatly appreciated.

Rick B.

I have this exact problem with Fedora Core 2. I'm able to connect just fine at home, where I have my own wireless access point, but if I walk across the street to the local cafe and try to connect to their public access point using a different "profile", I can't connect. Then when I return home, frustrated and feeling rather stupid, I can get my "home" profile to connect. I have to activate it, but it connects smoothly. I get the impression it might be because this is the first (or topmost) profile in the list of profiles I have. I've never been able to get any but the "home" profile to work.

Is there a fix for this?

Bob Cochran
Greenbelt, Maryland, USA


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]